Trouble generating docs for enums in VS 2010 project

Aug 12, 2010 at 5:49 PM
I have a VS 2010 project, that I am using Sandcastle (along with the Sandcastle help file builder - http://shfb.codeplex.com/) to generate docs for. I have the latest versions of both. I am running into an issue with enums - the docs contain the enum description, but not the enum field descriptions. For example: /// <summary> /// The gender of the user. /// </summary> public enum Gender { /// <summary> /// Male. /// </summary> Male, /// <summary> /// Female. /// </summary> Female } The docs for this enum contain the first sentence "The gender of the user.", but the members Male and Female don't have descriptions. Any ideas what's going on here? Thank you!
Editor
Aug 12, 2010 at 6:29 PM

There's a bug in the Sandcastle transformations that causes it to omit the description.  Download and apply the Sandcastle Styles patch to fix it and some other issues.

Eric

 

Aug 12, 2010 at 6:36 PM

Yay, it worked - thanks a lot!

Aug 19, 2013 at 7:13 AM
Hi Eric,

I have the same issue . Trouble in generating docs for enums in VS 2010 project and I am using Sandcastle 1.9.7.0 and Sandcastle Compiler tool 2.7.3.0.
I tried to download the Sandcastle Styles patch to fix it, but link is not available anymore. Can You give me solution for that.

Thanks.
Editor
Aug 19, 2013 at 4:56 PM