Sandcastle April 2012 v2.7.0.0 Now Available

Editor
Apr 16, 2012 at 4:50 AM

A new release of the Sandcastle tools is available. It has temporarily been published at the Sandcastle Styles project site. See the Sandcastle 2.7.0.0 Release Notes for full details.

 

Apr 19, 2012 at 10:28 PM

Yay! I'm glad you're taking charge.

I can't get the VS2010 style to build. I always get "BUILDASSEMBLER : error : BrandingComponent: Self-branding is required for [project type]"

Is this a known issue or did I screw something up?

Editor
Apr 20, 2012 at 2:21 AM

It depends on whether you are build MS Help Viewer output or not.  If you are building CHM or website output, you need to manually set the SelfBranded project property back to True in SHFB.  It gets forced to False when you select the VS2010 style with the assumption that you will be building MS Help Viewer output in which case, False is required.  It need to tweak the behavior of the property interactions to prevent this and also just force it to true in the component and have it issue a warning instead of just stopping.  This is the first release for the style and components so expect some issues like this that need to be worked out.  If you still can't get it to work, send me a small example so that I can diagnose the issue.

Eric

 

Apr 20, 2012 at 3:15 AM

You were right, 'SelfBranded' was set to false when I viewed it in the HFB GUI (the project was in VS11). I set it to true and it STILL didn't work.

Then I manually edited the project file and set the SelfBranded element to 'True' and everything seems to work fine now! The VS2010 style seems a bit off, but it's a work in progress, I know :) If I find some time, I'll try to spruce it up a bit for you.

Apr 27, 2012 at 3:07 PM

Hi, Eric! I want to localize the content folder for the Russian language. You can then enable content in Sandcastle as a folder ru-ru?

Editor
Apr 27, 2012 at 7:25 PM

Thanks for the offer.  Somebody sent me Russian translations a couple of days ago.  I'm going to merge them in for the next release of Sandcastle.  I can e-mail them to you if you'd like them before then.

Eric

 

Apr 28, 2012 at 1:36 PM

Through Visual Studio under Project Properties, MS Help Viewer,  someone have to check the option "The help file is self-branded". If is already checked then unckeck and check again. Save and build again. Project properties in Visual Studio shows that option checked event if it isn't.

Having the same problem as you, doing as above, I finally be able to build the documentation project.

Editor
Apr 28, 2012 at 6:34 PM

I'll have this fixed and a refresh published sometime tomorrow. The basic problem is a misunderstanding on my part on how the self-branded property was to be used. In the current release, it's being forced to false when the VS2010 style is selected which is incorrect. There's also a problem in how it's used in the configuration file templates for non-MS Help Viewer output. In reality, it should always be left set to true unless you want some default branding applied by the help viewer which typically is not what you'd want. Once the refresh is published and you've installed it, set the SelfBranded property back to true/checked and all should be well.

Eric

Apr 29, 2012 at 7:30 PM

Hi, Eric! I sent you my e-mail to notifications@codeplex.com