Help topics integrated into VisualStudio11 are not opening

May 17, 2012 at 9:38 AM
Edited May 17, 2012 at 9:40 AM

I'm trying to integrate some developer help I built with the latest Sandcastle release (April 2012 release from the SandcastleStyles project) into the Help Viewer 2.0 beta that's installed with Visual Studio 11 Beta. I'm using the new VS2010 style, and the HelpFileFormat of MSHelpViewer. If I run the Install_<helpcollection>.bat file thats created alongside the .mshc and .msha, the help collection installs just fine into the Help Viewer 1.0 for VS 2010 help.

So next, I used the following line to try installing the same collection to Help Viewer 2.0 for VS 11:

"%SYSTEMDRIVE%\Program Files (x86)\Microsoft Help Viewer\v2.0\HlpCtntMgr.exe" /operation install /catalogName VisualStudio11 /locale en-us /sourceUri "<Full_path_to_my_msha_file>"

And have found that when I open the VS 11 help, I can see the topics I expected in the TOC, but all topics show a completely blank page when selected, no errors or messages are shown, but it appears the page is still loading as the mouse cursor stays spinning if over the page.

I can see the imported msha, mshi and metadata files in the HelpLibrary2\Catalogs\VisualStudio11\ContentStore\en-US folder. I have built a different test project that is much smaller, and this has the same behaviour. I've also tried choosing some different styles, and get the same behaviour again.

I've seen the thread (here) with similar symptoms, but I am using the VS2010 style not the VS2005 style (I checked and those references to HxLink.css are not part of the new style).

I'm unsure where to start if I need to make other edits to the Sandcastle styles. So two questions really:

- Has anyone seen this behaviour, and have any advice of solutions to try.

- Does anyone have any advice on how to debug the issue? (My next step would otherwise be to post a bug on Microsoft Connect, but I was wondering if there was some way to view loading errors or other debug information from the Help Viewer).

Thanks for any advice.

Editor
May 17, 2012 at 3:04 PM

This is a known issue as listed in the release notes.  Don sent me some changes which should address that issue and I'll get them into the next release.  I have no time line for when that will be out yet.

Eric

 

May 17, 2012 at 3:20 PM

Thanks for pointing out what I'd missed Eric. So I'd tried the other help formats, and failed to get any of the styles loading in the viewer, including the VS2005 style - however the important bit was "It does support the self-branded VS2005 style." - when I switched styles I hadnt changed the Self branded setting - now I've set style to VS2005 and SelfBranded to True I can see the help topics display.

Thanks for releasing the update - it's going to be very useful, I've used Sandcastle very successfully in past projects and look forward to the next updates.

Ta, Shelly.