4
Vote

Right-Hand Pane Content Not Visible In IE 10, Windows CP 8

description

This is using the vs2010 Style of web site output, opening the top-level Index.html locally (as a file, not over http).
 
Normally, on older versions of IE on older versions of Windows, you will get the "unsafe content" bar, and as soon as you enable that, everything renders. But on IE 10, you never get that warning. Instead, you get the tree view of tops on the left, but just an empty blue background on the right, no matter what topic you click.

comments

shfbeval wrote May 23, 2012 at 12:11 PM

The same problem with IE10 reproduces with documentation over http not only from local files.

helpmaintainer wrote Jun 21, 2012 at 5:20 AM

This becomes a very serious issue. The right side content is not visible in the IE 10 from Windows 8 Release Preview and there is a little chance this will change in the final Windows 8 release. Are you going to adress this somehow? Or otherwise please provide a workaround.

EWoodruff wrote Jun 21, 2012 at 7:38 PM

I haven't had a chance to install the latest release candidate yet. I will get to it within a few weeks.

EWoodruff wrote Jul 25, 2012 at 11:26 PM

The problem is two-fold: IE 10 sizes the content pane differently than prior versions. It now acts like FireFox and Chrome so the width adjustment needs to be done the same as for them in the ResizeContent() method in TOC.js. The second issue which requires a tool change is that IE10 doesn't like the MS Help XML data element nor the "ms-help" stylesheet link in each topic. I need to update the SandcastleHtmlExtract tool to strip them out of the Help 1 and website build content.

Macharius92 wrote Jul 5, 2013 at 9:47 AM

Hi,

Is there any news about this issue ? We are using SHFB to generate online help (with Additional Content Only plugin)

We can't see it correctly in IE10 on Win7 (works great in other browsers)

I hope there will be soon an update as it's a major issue for us.

EWoodruff wrote Jul 5, 2013 at 4:09 PM

Make sure you are using the latest release of SHFB (1.9.7.0). The issue in question has been fixed for quite some time. I am currently seeing no issues with the website output in IE10 on XP, Windows 7, and Windows 8. If you've made any customizations to the website files, make sure you update your version of the files with the changes from the latest release.

Also, please note that this project has been discontinued and may not be monitored as frequently. For future questions or issues concerning Sandcastle or SHFB, post them over on the Sandcastle Help File Builder project's discussion page. Thanks.