1
Vote

SandCastle version out of date

description

Warning: If you are using SandCastle with the "SandCastle Hepl File Builder" and then for some reason install the Visual Studio 2005 SDK the "SHFB" will throw a message saying that SandCastle is out of date and it must be upgrade to the version v2.4.10111.0.
 
To solve this problem you have to override the old SandCastle version provided by VS2005 SDK whith the version that you had got from CodePlex. To do it you only have to remove all files and folders in "C:\Program Files\Visual Studio 2005 SDK\2007.02\VisualStudioIntegration\Tools\Sandcastle" and copy "C:\Program Files\Sandcastle". That's all.

comments

davedev wrote Mar 6, 2008 at 1:25 PM

This is a known issue and it's not specific to SHFB.

The solution is to delete the DXROOT user environment variable after installing an SDK. The latest release of Sandcastle installs a DXROOT system environment variable; commonly, C:\Program Files\Sandcastle.

Automation tools may need to be restarted. Sometimes the computer needs to be restarted as well for the changes to take affect.