Error BE0043 - MREFBUILDER : error : Unresolved assembly reference

May 9, 2011 at 3:13 PM
Edited May 9, 2011 at 3:17 PM

Another one of these I'm afraid. I've tried all the previously recommended solutions, including the Assembly Binding Redirection plug-in. 

Here is the error:

Generating reflection information...
  MrefBuilder (v2.6.10621.1)
  Copyright , Microsoft 2006
  Info: Loaded 69 assemblies for reflection and 49 dependency assemblies.
MREFBUILDER : error : Unresolved assembly reference: 
MindFusion.Diagramming (MindFusion.Diagramming, Version=, Culture=neutral, PublicKeyToken=a0d18338041985ba) 
required by MindFusion.Diagramming.WinForms [F:\Published documentation\Working\GenerateRefInfo.proj]
    Last step completed in 00:00:14.7858

SHFB: Error BE0043: Unexpected error detected in last build step.  See output above for details.

Only this version ( is used in the project. Here (I think) is the reference being found earlier in the log:

References to use:
And here is the HintPaths (which are correct, in a roundabout way, what with the absolute/relative path mix) from the GenerateRefInfo.proj file:
<Reference Include="MindFusion.Common">      
	<HintPath>F:\Visual Studio 2010\Projects\trunc\src\Desktop\GUI\..\..\..\libraries\MindFusionEvaluation\MindFusion.Common.dll</HintPath>    
<Reference Include="MindFusion.Diagramming">      
	<HintPath>F:\Visual Studio 2010\Projects\trunc\src\Desktop\GUI\..\..\..\libraries\MindFusionEvaluation\MindFusion.Diagramming.dll</HintPath>    
<Reference Include="MindFusion.Diagramming.WinForms">      
	<HintPath>F:\Visual Studio 2010\Projects\trunc\src\Desktop\GUI\..\..\..\libraries\MindFusionEvaluation\MindFusion.Diagramming.WinForms.dll</HintPath>    

Cheers, Matt

May 11, 2011 at 8:28 PM

It's most likely related to the problem in this SHFB work item:

I've never been able to duplicate the problem and haven't been sent a failing example so haven't found a fix.  According to the above work item, using the ReferencePath property may fix the issue.  I'll see about adding support for it to the next release to see if that fixes it.



Jan 5, 2012 at 9:29 AM

Try using Wildcard References Plug-In. Configure it to find problematic references. It worked out for me.