Is it possible to get a Logo next to a page title?

Mar 5, 2009 at 7:26 PM
I have converted an HTML topic to MAML using the HTML 2 MAML conversion tool from the Sandcastle styles project.  The conversion is far from push button, but the clean up was fairly painless.  Once issue I have is that I would like to have my logo appear next to the page title (Like on these codeplex pages with the Sandcastle logo).  Is that posible?  All the examples I have seen show the image links within a content tag.

Pat O
Mar 6, 2009 at 12:22 AM
>>Pat O: Is that posible?
There is nothing impossible with the Sandcastle, and in my implementation of the logo, 
I completely reorganize the header, and so have the control over adding or deleting parts.

>>Pat O: All the examples I have seen show the image links within a content tag.
I do not know which examples you have seen, but can you provide a picture of what you want?
(If you want google or related account upload it and provide the link here).

Best regards,
Mar 6, 2009 at 2:32 AM
Image links in the actual page header (the one rendered by the Sandcastle presentation style XSL transformations) can be added by a build component.  In SHFB, support is built in already via the Post-Transform Component.  Open up the ComponentConfiguration property, add it to the project, and configure it by selecting the logo image and placement options on the Logo File tab.

Mar 6, 2009 at 1:43 PM
Thanks Eric that is just what I was looking for.  Now I have a MAML question.  Given the following MAML:
<?xml version="1.0" encoding="utf-8"?>
<topic id="542d69da-f5fa-484c-9b4f-bebc356233ec" revisionNumber="1">

      <para>This is an overview of the CNX SDK from Cognex.</para>

      <para>CNX is a common foundation that can be used for communication by various Cognex machine vision platforms, applications, and user interface systems.</para>

      <title>CNX Overview</title>
        <mediaLink><image xlink:href="CNX SDK" /></mediaLink>

And given that I have an image registered in Conceptual Content as CNX SDK, why do I not get an image in my help file.  I get the following warning in my log:
Info: SaveComponent: Instantiating component.
Info: BuildAssembler: Building topic 542d69da-f5fa-484c-9b4f-bebc356233ec
Warn: ResolveArtLinksComponent: Unknown art target 'cnx sdk'
Info: BuildAssembler: Building topic 56f8e6f7-2d33-4d5a-a2d5-004b7fe491af
Info: Processed 2 topics

I also get stacks of warnings like this:
Warn: CopyFromIndexComponent: Entries for the key 'N:Cognex.Cnx' occur in both 'C:\views\pohara_cnx_current\cnx\TechDoc\SDK\@TOK_OUTPUT_PATH@\Working\6B284FD2\reflection.xml' and 'C:\views\pohara_cnx_current\cnx\TechDoc\SDK\@TOK_OUTPUT_PATH@\Working\reflection.xml'. The last entry will be used.

I don't think they are related, but I thought I would include them just in case.

I have read the guide and believe I am referencing the image correctly. 

Thanks for your time on this

Pat O

Mar 6, 2009 at 3:14 PM
It looks like you are perhaps using one of the plug-ins such as the version builder or additional reference links plug-ins.   In such cases, you may see those warnings if the same ID appears but they can be ignored.  I'm not sure why the image wouldn't be showing up if added to the project correctly.  You might check further back in the log where it copies the conceptual content stuff to see if it's actually picking it up.  If you can send me your project file, I'll take a look at it and see if I can see anything out of the ordinary.  Since this is SHFB related, we should probably move the discussion over to the SHFB project discussion board too.

Mar 6, 2009 at 8:44 PM
I created a thread over there

Pat O